QQ登录

只需一步,快速开始

80后炒股配资网

80后炒股配资网 80后网赚 选股技巧 查看内容

通达信指标源码大全,你们想要的统统都在这里,还有选股器哦

2021-3-3 17:15/ 发布者: fhfa860fww| 查看: 113/ 评论: 0


响应大家的要求今天就把指标和选股器的源码直接分享出来供大家周末研究学习,喜欢的朋友可以多多关注阿森哦~定期给大家分享你们喜欢的干货。话不多说直接切入正题。

通达信指标源码大全,你们想要的统统都在这里,还有选股器哦


【中阳穿底】选股公式

次新:=(BARSCOUNT(C)+1)<120;


MA30:=MA(C,30);


MA60:=MA(C,60);


MA120:=MA(C,120);


VAR1:=(MAX(C,O)-MIN(C,O))/MIN(C,O)*100;


VAR2:=(H-MAX(C,O))/MAX(C,O)*100;


VAR3:=MA(REF(LLV(C,30),1),2);


VAR4:=MA(REF(HHV(C,30),1),2);


VAR5:=MAX(MA30,MAX(MA60,MA120));


VAR6:=MIN(MA30,MIN(MA60,MA120));


VAR71:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));


VAR72:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);


VAR73:=REF(VAR72,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);


VAR74:=REF(VAR72 OR VAR73,1) AND VAR71;


VAR7:=VAR74 AND CLOSE>OPEN;


展开全文

VAR81:=IF(C>MA(C,4),1,0);


VAR82:=IF(C<MA(C,4),-1,0);


VAR83:=IF(MA(C,5)>REF(MA(C,5),1),1,0);


VAR84:=IF(MA(C,5)<REF(MA(C,5),1),-1,0);


VAR85:=VAR81+VAR82+VAR83+VAR84;


VAR8:=VAR85=2 AND C<O;


VAR91:= EMA((CLOSE*2+HIGH+LOW)/4,13)-EMA((CLOSE*2+HIGH+LOW)/4,73);


VAR92:=(CROSS(VAR91,EMA(VAR91,2)) AND VAR91<=0.05 AND (C/REF(C,1)>0.035));


VAR9:=VAR92 AND NOT(VAR8);


VAR10:=(C<VAR6 OR (C<VAR6*1.01 AND 次新)) AND C<VAR4 AND VAR6<VAR4 AND VAR6<=REF(VAR6,1);


VAR11:=VAR1>3.9 AND VAR1<8 AND C>OPEN AND VAR2<1 AND VAR9=0 AND REF(MAX(C,OPEN),1)>C AND VAR9=0 AND REF(VAR7=0,2) AND (REF(VAR9=0 AND VAR7=0,1) OR REF(MAX(C,O),1)>C);


XG:VAR11 AND VAR3=REF(VAR3,1) AND VAR10;


【神经过敏】选股公式

现价线:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1),COLORFF00FF,LINETHICK2;


确认线:=4*SMA((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,5,1)-3*SMA(SMA((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,5,1),3.2,1),COLORGREEN,LINETHICK2;


短底:=12,COLORBLUE,LINETHICK2;


穿越线:=CROSS(现价线,短底);


预警线:=IF(现价线<=10,30,0),COLORFFCC00,LINETHICK1;


XG:=FINANCE(7)<500000000;


预提:=IF(CROSS(现价线,短底),50,0),COLORRED,LINETHICK2;


预提 AND XG;


【反转骑牛】选股公式

EE:=REF(C,1)<REF(C,2) AND C>=O*1.035 AND (REF(H,2)=REF(HHV(H,40),1) OR REF(H,3)=REF(HHV(H,40),1) OR REF(H,4)=REF(HHV(H,40),1) OR REF(H,5)=REF(HHV(H,40),1) OR REF(C,2)=REF(HHV(C,40),1) OR REF(C,3)=REF(HHV(C,40),1) OR REF(C,4)=REF(HHV(C,40),1) OR REF(C,5)=REF(HHV(C,40),1)) AND REF(C,1)+(REF(C,1)*0.1)>=REF(HHV(C,40),1) AND REF(O,1)-REF(C,1)>REF(C,2)*0.01;


VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,V*240/FROMOPEN,DRAWNULL);


CC:=VVOL>REF(VOL,1) OR VOL>REF(VOL,1);


MA5:=MA(C,5);


MA10:=MA(C,10);


MA20:=MA(C,20);


MA30:=MA(C,30);


MA60:=MA(C,60);


FF:=MA5>MA10 AND MA10>MA20 AND MA20>MA30 AND MA30>MA60;


GG:=REF(V,1)<REF(MA(V,20),1) OR REF(V,2)<REF(MA(V,20),2) OR REF(V,3)<REF(MA(V,20),3) OR REF(V,1)<REF(MA(V,10),1) OR REF(V,2)<REF(MA(V,10),2) OR REF(V,3)<REF(MA(V,10),3);


MA5斜率:=ATAN((MA5/REF(MA5,1)-1)*100)*57.3>45;


EE AND CC AND FF;


【温馨强势股】选股指标公式

MID:=MA(CLOSE,26);


UPPER:=MID+2*STD(CLOSE,26);


LOWER:=MID-2*STD(CLOSE,26);


EXP1:=EMA(CLOSE,10);


EXP2:=EMA(CLOSE,60);


DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);


BIAN1:=REF(COUNT(C/REF(C,1)>1.053,15)>3,1);


A1:=MA(CLOSE,5);


A2:=MA(CLOSE,10);


A3:=MA(CLOSE,20);


A4:=MA(CLOSE,60);


A5:=MA(CLOSE,120);


A6:=MA(CLOSE,250);


ZHOUZHANG:=(CLOSE/REF(CLOSE,6)-1)*100<10;


QP:=REF(A1,1)*1.05>REF(UPPER,1);


QO:=REF(A1,2)*1.05>REF(UPPER,2);


QG:= A1*1.05>UPPER;


PPDAY22 := BARSLAST(CROSS(EXP1,EXP2));


DJC22 :=IF((PPDAY22<20 ),1,0);


DD :=C>A3 AND C>A1;


DS :=REF(CCI,1)<100 ;


A22:V/REF(V,1)<1 AND C<REF(C,1) AND REF(C,1)>REF(O,1) AND REF(C,1)>REF(A1,1) AND


C<O AND C<REF(C,1) AND BIAN1 AND DD AND DS AND REF(C,1)>REF(C,2) AND REF(C,2)<REF(A1,2) AND REF(C,1)>REF(A1,1) AND ZHOUZHANG;


【江浪花】选股公式

N:=20;


T:=10;


DI:=EMA(CLOSE,12)-EMA(CLOSE,26);


DA:=EMA(DI,9);


MM:=(DI-DA)*2;


MA1:=MA(CLOSE,10);


MA2:=MA(CLOSE,20);


MA3:=MA(CLOSE,30);


MA6:=MA(CLOSE,60);


浪花:MA1>REF(MA1,1) AND MA2>REF(MA2,1) AND MA3<REF(MA3,1) AND V<REF(V,1)*0.6 AND C>MA(C,60),COLORYELLOW;


【擒妖猎牛】副图指标公式

M:=55;


N:=34;


LC:=REF(CLOSE,1);


RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);


FF:=EMA(CLOSE,3);


MA15:=EMA(CLOSE,21);


VAR1:=IF(YEAR>=2038 AND MONTH>=1,0,1);


VAR2:=REF(LOW,1)*VAR1;


VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100*VAR1;


VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3)*VAR1;


VAR5:=LLV(LOW,30)*VAR1;


VAR6:=HHV(VAR4,30)*VAR1;


VAR7:=IF(MA(CLOSE,58),1,0)*VAR1;


VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7*VAR1;


吸筹:IF(VAR8>100,100,VAR8)*VAR1,COLORRED;


庄家吸筹:STICKLINE(吸筹>-150,0,吸筹,8,0),COLORRED;


散户: 100*(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M)),COLORYELLOW,LINETHICK2;


RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;


K:=SMA(RSV,3,1);


D:=SMA(K,3,1);


J:=3*K-2*D;


庄家:EMA(J,6),COLORLIRED,LINETHICK2;


第一买点:DRAWTEXT(CROSS(14,吸筹),10,'买1'),COLORYELLOW;


第二买点:DRAWTEXT(CROSS(庄家,散户) AND 庄家<50,30,'买2'),COLORRED;


第一卖点:DRAWTEXT(CROSS(88,庄家),80,'卖1'),COLORGREEN;


第二卖点:DRAWTEXT(CROSS(散户,庄家),60,'卖2'),COLORCYAN;


【九转MACD】副图指标公式

DIF:EMA(C,12)-EMA(C,26);


DEA:EMA(DIF,9);


MACD:(DIF-DEA)*2,COLORSTICK;


STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,0.5,0),COLORLIRED;


STICKLINE(MACD<REF(MACD,1) AND MACD<0,0,MACD,0.5,0),COLORLIGREEN;


A1:=C>REF(C,4);


NT:=BARSLASTCOUNT(A1);


TJ11:=NT=9;


TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);


AY:=(BACKSET(TJ11>0,9) OR BACKSET(TJ13>0,NT))*NT;


DRAWTEXT(AY>0,MAX(DIF,MACD)*1.1,VAR2STR(AY,0)),COLORGREEN;


DRAWTEXT(NT=9,MAX(DIF,MACD)*1.1,'9'),COLORGREEN;


B1:=C<REF(C,4);


NT0:=BARSLASTCOUNT(B1);


TJ21:=NT0=9 ;


TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);


AY1:=(BACKSET(TJ21>0,9) OR BACKSET(TJ23>0,NT0))*NT0;


DRAWTEXT(AY1>0,MIN(DIF,MACD)*1.2,VAR2STR(AY1,0)),COLORLIMAGENTA;


DRAWTEXT(NT0=9,MIN(DIF,MACD)*1.2,'9'),COLORMAGENTA;

通达信指标源码大全,你们想要的统统都在这里,还有选股器哦


上方是我自己搭配的一套组合指标,最近用的还不错。不知道大家感不感兴趣,有喜欢的朋友可以直接转发关注、下方评论区留言我直接给大家分享。今天就先到这里祝大家周末愉快!!!


鲜花

握手

雷人

路过

鸡蛋
分享到:
更多

最新文章

【股票k线图基础知识】股票K线图入门基础知识之底部实战
【股票k线图基础知识】股票K线图入门基础知
股票学习网(www.qh171.com)6月3日消息 在逐渐成熟的a股投资市场,对于基本投资经验很少或...
【股票市场入门】如何选股?老股民总结常见的买股技巧
【股票市场入门】如何选股?老股民总结常见
如何选择股票?老股东总结普通股购买技巧2018-04-27 09336038财富电网综合 在股票市场,...
股票基础知识之:如何选择一直好的股票
股票基础知识之:如何选择一直好的股票
首先,你应该设计一个利润模型。做股票和做任何生意是一样的。做什么,什么时候做最好,以...
【什么手机炒股好】股票简单的赚钱的四大“绝招”(4)
【什么手机炒股好】股票简单的赚钱的四大“
在中国日益成熟的股票投资市场,建议刚接触股票交易新手的朋友和没有基本知识的投资者在进...
【干部辞职炒股】股市奇才揭秘MACD买卖战法 简单高效 掌握可低买高卖 ...
【干部辞职炒股】股市奇才揭秘MACD买卖战法
2.销售技巧 当DIF线从上到下穿过DEA线时,MACD死叉形成。如果死叉出现在零轴上方,这...
三分钟让你学会换手率选股技巧,别说我没教你
三分钟让你学会换手率选股技巧,别说我没教
一、换手率高的情况分类1、相对高位成交量突然放大,主力派发的意愿很明显。然而,在高位放...
返回顶部